Home > Hack, Linux Experience, Networking, Tips n Trick > Review Huawei HG553 yang sudah diganti ke OpenWRT/LEDE

Review Huawei HG553 yang sudah diganti ke OpenWRT/LEDE

Huawei HG553 merupakan router ADSL (bekas) yang dibundling oleh operator Vodafone. Di Indonesia, router ini menjadi favorit karena harganya yang murah meriah. Saya sendiri sudah pakai 2 buah, dibeli dengan harga 140rb. Sangat murah bila dibandingkan dengan TPLink MR3240. Secara kemampuan, router ini mirip dengan TPLINK MR3420, ada port USB nya. Tapi sayangnya bentuknya besar sekali dan antena hanya antena internal.

Sekalipun begitu, saya amati router ini cukup tangguh, pernah di tempat yang saya pasang, ada 27 perangkat yang terkoneksi. Memang sih sebagian besar perangkat yang terkoneksi hanya idle, tidak ada data yang dilewatkan, tapi walaupun demikian, perangkat yang terkoneksi tidak mengalami kemacetan saat mulai mengakses jaringan.

Kelemahan HG553:

  1. Bentuk besar dan tebal. Kalau anda suka yang elegan, router ini tidak cocok buat anda. Saya pribadi sangat nggak sreg dengan bentuknya.
  2. Antena internal
  3. CPU hanya 300 MHz, tidak masalah kalau hanya sekedar Access Point, mulai bermasalah bila dipakai untuk sharing file.

Kelebihan HG553:

  1. Murah meriah, itu julukan router satu ini.
  2. Stabil, walau pengguna banyak. Ingat ya, stabil, bukan kencang.
  3. Ada port USB, yang satu untuk modem, yang satu untuk Harddisk.
  4. Komunitas pengguna banyak, bisa openwrt.

Ok, untuk upgrade ke OpenWRT, mutlak dilakukan langkah-langkah ini:

  1. Atur IP komputer ke 192.168.1.x, dan hubungkan ke salah satu port LAN yang ada pada HG553
  2. Download file yang diperlukan, yaitu openwrt-HW553-squashfs-cfe.bin atau versi LEDE lede-17.01.0-r3205-59508e3-brcm63xx-generic-HG553-squashfs-cfe.bin
  3. Buka terminal, dan ketik ping 192.168.1.1
  4. Nyalakan HG553 sambil tekan tombol reset kira-kira 30 detik. Sambil amati apakah ping sudah reply atau belum.
  5. Bila sudah reply, buka browser dan masuk ke alamat 192.168.1.1
  6. Upload file openwrt-HW553-squashfs-cfe.bin atau file LEDE yang sudah didownload, tunggu kira-kira 2-3 menit. Memang agak lama, saya sendiri sempat mengira router hang.
  7. Bila berhasil, ping akan reply, dan lampu router akan kedip-kedip. Dan akhirnya menyala satu lampu lagi, di sebelah kiri lampu power (gambar recycle?)
  8. Masuk lewat browser ke 192.168.1.1 lalu atur password supaya bisa login lewat SSH

Karena HG553 tidak mempunyai port WAN karena hanya ada 1 ethernet, anda bisa menambahkan dengan bantuan VLAN Tag. Untuk port WAN, VLAN ID nya adalah 2. Port WAN yang ditambahkan adalah di port 4 (IP/TV). Caranya sebagai berikut (pakai SSH lebih cepat):
1. SSH ke HG553, isikan username: root, lalu isikan password
2. Edit file /etc/config/network dengan menggunakan vim
vim /etc/config/network
tekan tombol “i” untuk insert/edit
3. Ubah/tambah bagian ini. Kalau menggunakan LEDE, bagian device akan tertulis ‘switch0’
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 5t'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '3 5t'

config interface 'wan'
option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'dhcp'

4. Simpan dengan perintah :wq
5. Restart router, lalu login via web kalau anda membutuhkan pengaturan WAN lebih lanjut.

Tambahan
Bila anda memerlukan dua VLAN ID dalam 1 port yang sama, misalnya di port 4 menggunakan VLAN8 dan VLAN10, silahkan edit seperti dibawah ini. Sebagai contoh, saya memberikan ip address ke VLAN8 tapi hanya VLAN tag di VLAN10 karena VLAN10 langsung saya bridge dengan Wireless.
config interface 'VLAN8'
option ifname 'eth0.8'
option proto 'static'
option ipaddr '192.168.101.22'
option netmask '255.255.255.0'
option gateway '192.168.101.1'
option broadcast '192.168.101.255'
option dns '192.168.1.250'

config interface 'VLAN10'
option ifname 'eth0.10'
option type 'bridge'
option auto '1'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 5t'

config switch_vlan
option device 'eth0'
option vlan '10'
option ports '3t 5t'

config switch_vlan
option device 'eth0'
option vlan '8'
option ports '3t 5t'

Perhatikan ada tanda “t” di option ports, maksudnya adalah berikan VLAN Tag karena ini 2 VLAN dalam 1 port.

Untuk referensi:

https://wiki.openwrt.org/toh/huawei/hg553

Advertisements
  1. tres
    May 8, 2017 at 10:37 am

    gan modem m2s nya blm bsa diunlock ngga?

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: