Home > Hack, Linux Experience, Networking, Tips n Trick > OpenWRT 8.09 di Linksys WRT54GL dengan VLAN

OpenWRT 8.09 di Linksys WRT54GL dengan VLAN

Tulisan ini merupakan bagian dari tulisan saya tentang pemisahan jaringan berdasarkan VLAN. Jaringan yang dipisahkan adalah LAN ke VLAN, dan Wireless ke VLAN, firmware yang digunakan pada tulisan ini adalah OpenWRT 8.09. Untuk versi DD-WRT  bisa dibaca disini.

Tutorial ini akhirnya saya tulis karena susahnya mencari informasi tentang VLAN di WRT54GL. Beberapa tutorial yang sempat saya lihat menggunakan ddwrt, tapi entah kenapa saya coba kok tidak bisa, mungkin karena versi hardware nya lain. Saya menggunakan WRT54GL V1.1 yang saya upgrade dengan menggunakan OpenWRT 8.09. Nah, kenapa 8.09? dan bukan 10.03 atau yang terbaru sekalian macam 12.09? Jawabannya bisa anda buka dari wiki openwrt. Kalau hanya sebatas Access Point dengan VLAN, anda tidak membutuhkan versi terbaru. Versi lama asal stabil sudah cukup.

Adik saya sudah saya minta oprek router ini mulai dari OpenWRT 10.03 hingga DDWRT dan selalu mentok, router tidak mau memberikan VLAN atau bridge tidak berjalan. Yang saya harapkan dari router ini adalah kemampuan VLAN TAG karena saya ingin memisahkan jaringan wireless ke VLAN10. Rencananya VLAN10 ini akan diberikan ipaddress dan hotspot service oleh server mikrotik.

Ceritanya, saya agak ngotot mencoba oprek router ini karena saya pernah berhasil membuat VLAN dengan TPLINK WR741ND. Walau arsitekturnya berbeda, tapi karena ini Linux, mestinya penghalang utamanya hanya hardware. Jadi kalau chip switch di router WRT54GL tidak punya kemampuan VLAN (8021q), mestinya dari skala software (kernel) bisa diatasi (kecepatan proses lebih lambat daripada langsung hardware).

bagian belakang router

bagian belakang router

Ok, dari skema di wiki openwrt didapatkan bahwa WRT54GL mempunyai 2 interface jaringan, yaitu eth0 dan wl0. Sedangkan eth0 sendiri merupakan switch yang dibagi berdasarkan VLAN0 (LAN) dan VLAN1 (WAN). Secara logika, mestinya bisa ditambahkan VLAN lain sebanyak port yang tersedia, tapi ingat hardware WRT54GL tergolong rendah, jadi walau anda bisa membuat 5 VLANID, tapi belum tentu stabil.

Versi openwrt yang saya pilih adalah 8.09 yang cukup stabil dan yang saya suka dibandingkan dengan versi 10.03 adalah kemampuan untuk membuat VLAN TRUNK. Di versi 10.03 anda hanya disuguhi TAGGED/UNTAGGED/DISABLE  berupa listbox di tiap port. Nah, kali ini saya ingin membuat port4-LAN menjadi port yang mempunyai VLAN dengan ID=10.

OS yang saya gunakan Linux karena sudah mencakup telnet dan ssh client. Bila anda menggunakan Microsoft Windows, bisa menggunakan putty. Saya mengasumsikan bahwa anda sanggup melakukan flash firmware maupun reset router. Disini saya hanya membahas konfigurasi jaringan saja. Untuk file silahkan download disini.

Berikut topologi jaringan yang akan saya buat:

linksys-wrt54gl-vlan

IP Address default untuk router baik di OpenWrt maupun DD-WRT adalah 192.168.1.1, jadi sebaiknya anda atur IP Address komputer ke 192.168.1.2

Berikut adalah langkah-langkahnya:

Cara yang paling praktis adalah menggunakan terminal dan editor vim.

1. Masuk ke failsafe-mode nya OpenWrt untuk memberi pengamananan pengaturan NVRAM

Setelah anda berhasil flash firmware, cabut+nyalakan kembali adaptor power. Tunggu sampai lampu DMZ menyala lalu segera tekan tombol Reset, maka lampu DMZ akan berkedip-kedip. Ini tandanya OpenWrt sudah berjalan pada failsafe-mode. Lalu telnet ke router dan paste perintah berikut:

nvram set boot_wait=on
nvram set boot_time=10
nvram set wait_time=10
nvram commit && reboot

2. Buka terminal lalu edit 2 file, yaitu /etc/config/network dan /etc/config/wireless dengan menggunakan vim. IP Address, VLAN ID, dan Wifi SSID bisa disesuaikan sesuai kebutuhan.

3. Berikut isi file /etc/config/network

vim /etc/config/network

#### VLAN configuration

config switch eth0

option vlan0 “0 1 2 3 5*”

option vlan8 “4t 5”

option vlan10 “4t 5”

option vlan13 “4t 5”

 

#### Loopback configuration

config interface loopback

option ifname “lo”

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

 

#### LAN configuration

config interface lan

option type bridge

option ifname “eth0.0”

option proto static

option ipaddr 192.168.88.1

option netmask 255.255.255.0

 

#### WAN configuration

config interface VLAN10

option ifname “eth0.10”

option type bridge

option proto static

option ipaddr 192.168.110.38

option netmask 255.255.255.0

 

config interface VLAN13

option ifname “eth0.13”

option type bridge

option proto static

option ipaddr 192.168.200.38

option netmask 255.255.255.0

 

config interface VLAN8

option ifname “eth0.8”

option proto static

option ipaddr 192.168.101.38

option netmask 255.255.255.0

Untuk edit tekan tombol “i”, setelah selesai tekan ESC, lalu ketik “:wq”

4. Berikut isi file /etc/config/wireless

config ‘wifi-device’ ‘wl0’

option ‘type’ ‘broadcom’

option ‘channel’ ‘6’

option txpower 23

option ‘frameburst’ ‘1’

# option ‘distance’ ‘300’

 

config ‘wifi-iface’

option device wl0

option network VLAN10

option mode ap

option ssid WLAN10

option encryption psk

option key “ini_passwordnya”

option isolate 1

 

config wifi-iface

option device wl0

option network VLAN13

option mode ap

option ssid WLAN13

option encryption psk

option key “ini_passwordnya”

option isolate 1

Untuk edit tekan tombol “i”, setelah selesai tekan ESC, lalu ketik “:wq”

5. Matikan dan restart router. Konfigurasi sudah selesai terpasang.

Perhatikan bagian yang saya tandai dengan BOLD.

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: